Back to overview
Degraded
Turk Telekom backbone failure
May 15 at 01:02am GMT+3
Affected services
Istanbul B
Istanbul D
Resolved
May 15 at 02:36am GMT+3
they got my 8 inch cock out of their ass and finally fixed the issue
Affected services
Istanbul B
Istanbul D
Created
May 15 at 01:02am GMT+3
Turk Telekom's something somewhere has failed for some reason and it affects A LOT of customers right now according to x the everything app. guess who it doesnt affect? me. and none of my shit. but still pings are fucking crazy, so here is an incident
Affected services
Istanbul B
Istanbul D